Lab 5
CSE 3, Winter 2016
In this lab you will manipulate financial data using advanced spreadsheet skills with Microsoft Excel. You will then analyze the performance of your career related stocks and investments and make a slide show on the analysis using Microsoft PowerPoint.

A. Stock Performance

As we saw in Lab 4, Excel is a useful tool for managing, manipulating, and analyzing financial data. To help us explore Excel more fully in this lab we are going to analyze the performance of the stocks of some companies related to your career in which you may want to invest your money in the future.

Step 1:
Create a Lab5 folder in your CSE3 folder.
Open a new Microsoft Excel spreadsheet and save it as Stocks.xlsx in your Lab5 folder.

Step 2:
Create a list of the companies you selected (Can’t be completely the same as example).
• To select companies and find their stock prices, go to http://finance.google.com/. At the bottom of the page you will find listing of different companies by sectors, which may help you choose your companies. (If the sector you select says “Did not find any companies for this category,” press Stock Screener to the left of the screen. In the drop down box for Sectors, chose which sector you want to select companies from. Then make your selection from the list that shows.) Alternatively, if you know what companies you want, you can just type in the name in the search box on the top instead of browsing the list by sectors. Select four different companies. At least two of the companies you select should be from sectors related to your future career.
• For the fifth “company”, we will look at something a bit different. We will examine a different type of investment: the Bitcoin market (learn more here: http://www.coindesk.com/information/what-is-bitcoin/). Note that this type of investment is not the same as stock trading, and investing in Bitcoin remains a highly controversial topic. For the purposes of this lab, we will treat this as a “stock” and Bitcoin as a “company”, though it is really a currency.
• In cell B4, type the heading Company Name and list the names of the four companies you selected in cells B5:B9. Select row 4 (where the ‘Company Name’ heading is) and underline and italicize. This row will be the heading of the table.
• For each company get the Close Price of shares for the dates of our first 4 labs. You can find the past prices under the ‘historical prices’ link and under weekly listing for each company in the website http://finance.google.com/. For Bitcoin, get the closing price from the Coindesk website (http://www.coindesk.com/price/). There should be a
“Download Historical Price Data” button that links to a .csv file with closing prices. This can be opened in Excel.

- In the cells C4:F4, list the four dates. Set the cell format to date format.
- After you have copied the data from the website your table should look something like this:

![Excel Table](image)

**B. Comparison of Prices**

Now we will create a column chart that shows us the comparison between the prices for each company for the chosen four dates.

- Select the data in the table B4:F9. Go to the Charts menu and select **Bar Charts**.

![Bar Chart Menu](image)

- Change the title to “**Comparison of Prices**”
- You can play with the different preset styles under **Chart Styles**.

![Chart Styles](image)

- You should end up with something similar to this:
Suppose you bought 10 shares of each of these five companies on the first day of lab. We would like to calculate how much you would have invested in stock.

- Create two columns with headings **Shares** and **Investment**. Put number ‘150’ under the # Shares column in each cell for each company. You can use the **Autofill** feature by putting ‘150’ in the top cell and dragging to fill in the other cells.
- Fill the Investment column with the formula for multiplying shares with the stock prices for lab 1. That is, you want to multiply the values in the columns C and G and put the results in column H. The formula in cell H5 should be: ‘=C5*G5’. Drag and autofill the rest of the values for that column.
- Now we would like to see the total investment. Underneath the table create a new row heading **Total** and under the H column calculate the sum. You can use the **autosum** feature.

---

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Company Name</td>
<td>11-Jan</td>
<td>19-Jan</td>
<td>25-Jan</td>
<td>1-Feb</td>
</tr>
<tr>
<td>5</td>
<td>T-Mobile US Inc.</td>
<td>39.68</td>
<td>37.65</td>
<td>37.89</td>
<td>40.59</td>
</tr>
<tr>
<td>6</td>
<td>AT&amp;T Inc.</td>
<td>33.9</td>
<td>34.51</td>
<td>35</td>
<td>36.18</td>
</tr>
<tr>
<td>7</td>
<td>Verizon Communications Inc.</td>
<td>45.09</td>
<td>44.87</td>
<td>47.03</td>
<td>50.76</td>
</tr>
<tr>
<td>8</td>
<td>Sprint Corp.</td>
<td>3.36</td>
<td>2.64</td>
<td>2.52</td>
<td>3.07</td>
</tr>
<tr>
<td>9</td>
<td>Bitcoin</td>
<td>448.3</td>
<td>377.7</td>
<td>390.6</td>
<td>371.2</td>
</tr>
<tr>
<td>10</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Comparison of Prices**

![Comparison of Prices](image)
Now we want to see the relative portion of our investment in a pie chart. Select the company names B4:B9. Then hold the Ctrl key while selecting the investment H4:H9 (so that the company names and investments are selected at the same time).

Under the insert tab, again select Charts. This time choose Donut and select OK. (For some computers the “donut” chart may be under ‘other’).

Select the newly created pie chart and under the Design tab, use the Quick Layout button to choose a layout style that has percentages. Make sure to rename this chart “Investment.”

You should end up with something like this:

D. Profit/Loss

Now we want to find out the percent profit or loss for each share and display them on a chart.

Create three columns with headings Current value, Income and %Profit/Loss. In the Current value column we calculate the current value of the stock with a formula for multiplying # shares with the prices of the latest week. You want to multiply the values in
the columns F and G and put the result in column I. The formula in I5 should be: ‘=F5*G5’. Drag and autofill the rest of the values for that column.

• Now we would like to see the total current value of stock. In the Total row under the I column calculate the sum using the autosum feature.

• To compute the income subtract the values in the column Investment from the Current value. You can use this formula ‘=I5-H5’. Drag and autofill the rest of the values for that column. Also compute the total income.

• The %Profit/Loss can be calculated from Income and Investment with the formula %Profit/Loss = Income / Investment * 100%. You can use this formula ‘=J5/H5*100’. Drag and autofill the rest of the values for that column.

• In the %Profit/Loss column, we want to restrict the number of digits after the decimal point. Select the data in that column and under the Home tab in the Number section select Number in place of General. After you do this your table should look like this:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Company Name</td>
<td>11 Jan</td>
<td>19 Jan</td>
<td>25 Jan</td>
<td>1 Feb</td>
<td>Shares</td>
<td>Investment</td>
<td>Current Value</td>
<td>Income</td>
<td>% Profit/Loss</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>T-Mobile US Inc.</td>
<td>39.68</td>
<td>37.65</td>
<td>37.89</td>
<td>40.59</td>
<td>150</td>
<td>5552</td>
<td>6066.5</td>
<td>136.5</td>
<td>2.29</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>AT&amp;T Inc.</td>
<td>33.90</td>
<td>34.51</td>
<td>35</td>
<td>36.18</td>
<td>150</td>
<td>5085</td>
<td>5427</td>
<td>342</td>
<td>6.72</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Verizon Communications Inc.</td>
<td>45.00</td>
<td>44.87</td>
<td>47.03</td>
<td>50.76</td>
<td>150</td>
<td>6763.5</td>
<td>7614</td>
<td>850.5</td>
<td>12.57</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Sprint Corp.</td>
<td>3.36</td>
<td>2.64</td>
<td>2.52</td>
<td>3.07</td>
<td>150</td>
<td>504</td>
<td>460.5</td>
<td>-43.5</td>
<td>-8.63</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Bitcoin</td>
<td>448.3</td>
<td>377.7</td>
<td>390.6</td>
<td>371.2</td>
<td>150</td>
<td>67245</td>
<td>55680</td>
<td>-11565</td>
<td>-17.20</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total</td>
<td>85549.5</td>
<td>75270</td>
<td>80279.5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

• Now we want to see the %profit and loss in a column chart. Select the company names B4:B9 and %Profit/Loss K4:K9 together holding the Ctrl key.

• Again, use the Recommended Charts button under the Insert tab. This time choose the Stacked Column chart type. As before, you can play around with the Chart Styles and layout options under Quick Layout in the Design tab. You should get something like this:
E. Function IF

One of the most powerful features in Excel is to evaluate data conditionally based on its value.

Let’s say we want to evaluate our stocks’ growth based on the percent profit and loss. We want to add a new column that tells us about the growth of each company. We can accomplish this with the use of IFs, ANDs, and ORs. Suppose we classify a company as rising if %profit/loss for that company is greater than 3.00%, falling if %profit/loss is less than -3.00%, and neutral otherwise.

The if formula has the following format:

IF( value_to_test, result_if_true, result_if_false ). Let’s see how this works by entering in an example.

- Create a new column with heading Growth and click on the first cell L5. We are going to enter a formula here
- Click either the formula builder button or the function icon on the formula bar.
- Look for and select IF.
- In the dialog box
  - Enter value1 as “K5”
  - Now choose “> greater than”
  - For value2 enter “3”
  - For then enter “Up” Be sure to include the quotation marks!
- Select OK
- Now use the fill handle to copy the formula to cells L5:L9.

We also wanted to rate stocks as falling if %profit/loss < - 3.00%, and neutral otherwise. We need to add a ‘if’ again in formula to our cell. If the test for rising is false then we want to test for falling. What we need to do is nest another ‘if’ formula inside of our ‘if’ formula. This is called nested if. Let’s edit the formula we have in L5:

- Select Cell L5
- Click one of the formula buttons. You should see the function arguments dialog box
- In false enter IF(K5<-3,"Down","Stable")
- Use the fill handle to copy our new formula to L5:L9
Your spreadsheet should look similar to this:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td><strong>Company Name</strong></td>
<td>11-Jan</td>
<td>18-Jan</td>
<td>25-Jan</td>
<td>1-Feb</td>
<td>Shares</td>
<td>Investment</td>
<td>Current Value</td>
<td>Income</td>
<td>%Profit/Loss</td>
<td>Growth</td>
</tr>
<tr>
<td>3</td>
<td>T-Mobile US Inc.</td>
<td>39.68</td>
<td>37.65</td>
<td>37.89</td>
<td>40.59</td>
<td>150</td>
<td>5952</td>
<td>6088.5</td>
<td>136.5</td>
<td>2.29</td>
<td>Stable</td>
</tr>
<tr>
<td>4</td>
<td>AT&amp;T Inc.</td>
<td>33.9</td>
<td>34.51</td>
<td>35</td>
<td>36.18</td>
<td>150</td>
<td>5085</td>
<td>5427</td>
<td>342</td>
<td>6.73</td>
<td>Up</td>
</tr>
<tr>
<td>5</td>
<td>Verizon Communications Inc.</td>
<td>45.09</td>
<td>44.87</td>
<td>47.03</td>
<td>50.76</td>
<td>150</td>
<td>6763.5</td>
<td>7614</td>
<td>850.5</td>
<td>12.57</td>
<td>Up</td>
</tr>
<tr>
<td>6</td>
<td>Sprint Corp.</td>
<td>3.36</td>
<td>2.64</td>
<td>2.52</td>
<td>3.07</td>
<td>150</td>
<td>504</td>
<td>480.5</td>
<td>-43.5</td>
<td>-8.63</td>
<td>Down</td>
</tr>
<tr>
<td>7</td>
<td>Bitcoin</td>
<td>448.3</td>
<td>377.7</td>
<td>390.6</td>
<td>371.2</td>
<td>150</td>
<td>67245</td>
<td>55680</td>
<td>-11560</td>
<td>-17.20</td>
<td>Down</td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Using this same condition we also would like to shade in the cells indicating our profit/loss status.

- First, make sure you are in the ‘Home’ tab.
- Not select the cells that correspond to our %Profit/loss column.

Now click on the conditional formatting button.
- Select ‘color’ scales and choose a color scheme. You can play around with the settings and choose colors that you like.

Your spreadsheet should look similar to this:
F. Making a prediction

The calculation feature of Excel not only allows us to make visual representation of what happened in the past, it also allows us to make simple rules in terms of formula to predict future value. We will be using the stock prices of the four weeks to forecast the price for the 5th week. The trend function calculates or predicts the future value (in this case 5th value) along a linear trend using existing four values.

For the purpose of this lab, we will be using the Excel ‘TREND()’ function to predict future price of stocks. Then we will calculate the income based on the predicted price. We want to add three new columns Trend, Predicted Value and Predicted Income.

- In the cell M5, insert the Trend() function.
- Use the following function: ‘=TREND(C5:F5, {1, 2, 3, 4}, 5)’ to predict the price for the 5th week. Drag the mouse to Autofill the forecast for the other stocks. (You can also use the formula builder to help you.)
- Then using the formulas Predicted Value = #Shares * Trend and Predicted Income = Predicted Value – Investment fill out the two columns.
- Use the auto sum function to total the predicted values and predicted income, giving us something similar to the following:

Your spreadsheet should look similar to this:

<table>
<thead>
<tr>
<th>K</th>
<th>L</th>
<th>M</th>
<th>N</th>
<th>O</th>
</tr>
</thead>
<tbody>
<tr>
<td>%Profit/loss</td>
<td>Growth</td>
<td>Trend</td>
<td>Predicted Value</td>
<td>Predicted Income</td>
</tr>
<tr>
<td>2.29</td>
<td>Stable</td>
<td>39.695</td>
<td>5954.25</td>
<td>2.25</td>
</tr>
<tr>
<td>6.73</td>
<td>Up</td>
<td>36.73</td>
<td>5509.5</td>
<td>424.5</td>
</tr>
<tr>
<td>12.57</td>
<td>Up</td>
<td>51.73</td>
<td>7759.5</td>
<td>996</td>
</tr>
<tr>
<td>-8.63</td>
<td>Down</td>
<td>2.65</td>
<td>397.5</td>
<td>-106.5</td>
</tr>
<tr>
<td>-17.20</td>
<td>Down</td>
<td>342.35</td>
<td>51352.5</td>
<td>-15892.5</td>
</tr>
</tbody>
</table>

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>70973.25</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-14576.25</td>
</tr>
</tbody>
</table>

Spend some time thinking about whether you want to buy/sell some stock based on comparison of your current income and predicted income.
G. Cell Merging

Now we would like to put a title for the table that will be at the top-center of the table.

- Select the cells B2:O2.
- Select Merge& Center in the Home tab.

- Type Stock Performance with large font size in the merged cell. Be creative! You can bold, underline, or change the title to stand out.

Your final spreadsheet should look something like this:

![Spreadsheet with merged cell and title](image)

H. PRESENTATION

Now we will create a presentation with all the charts you have created.

**Step 1:**
Start up PowerPoint by going to Start => All Programs => Microsoft Office => Microsoft Office PowerPoint 2013 and save it as Stock.s.pptx in your CSE3/Lab5 folder.

**Step 2:**
You’ll see two empty boxes. The first one should be the title of your presentation. Something like Stock Performance. The second box should have your name.

**Step 3:**
Select the Design tab on the Ribbon and select a Theme you like from the Themes group.
Step 4:
Now insert a new slide by going to **Home tab** and selecting **New Slide** from the Slides group. Choose Title and Content as your slide type. You should now see a blank slide.

Step 5:
Switch back to your **Stock.xlsx** page and copy a chart using Ctrl-C. Use Ctrl-V to paste the chart into the body of the slide. Give your slide a title.

Step 6:
Now for the most fun part of the lab—animations!
- Select part of your slide – the title or the chart itself.
- Choose the **Animations tab** on the Ribbon and select the **Animation Pane** button in the Advanced Animation group.
- A new pane should open up on the right-hand side of your screen.
- Click **Add Animation** and play with some of the animations.

Step 7:
In the **Insert Tab** select **Header & Footer**. The dialogue box below will pop up.
- Select “Date and time”, and “Fixed” to automatically put today’s date on every slide.
- Select “Slide number” to number the slides.
- Select “footer” and type “**CSE 3 Lab 5, Winter 2016**” to label each slide as being part of this lab.
- Select the “Don’t show on title slide” box, to keep the title slide clean.
- Finally, press the Apply to All button to apply these updates to every slide.

Step 8:
Create new slides and insert the rest of your charts into the presentation. Add an animation to each new slide. You will notice that your Footer automatically appears on the new pages. Save everything. You should have a total of **4 slides** when you’re done.
- One title slide
- 3 slides with Charts

I. Putting it all online

Step 1:
Save your **Stocks.pptx** file as PDF file named **Stocks.pdf**. Modify your **CSE3Page.html** to include **links to your Stocks.pdf** file.

Step 2:
Put everything online and get checked off.

Please be sure to close both Microsoft Excel and PowerPoint before transferring your files.
REMEMBER to either drag your ENTIRE CSE3 folder into your public_html folder OR into the WHITESPACE inside the public_html folder!!!

Take a minute and think about how you have multiple COPIES of your Excel files and PPT files – on your computer and on the internet. These are separate and unique, though copies of one another.

**Lab Checkoff:** Demonstrate to the TA/Tutor

- **Spreadsheet**
  - Four companies and Bitcoin closing prices
  - The three charts showing Comparison of Prices, Investment and %Profit/Loss.
  - Working “growth” column formula and conditional formatting.
  - Working “trend” column formula and predicted income.
  - The title with the merged cell.

- **Presentation**
  - One title slide
  - 3 slides with Charts
  - Working footer