**A. General Budget**

It is useful to have a budget to keep track of your earnings and your expenses. Microsoft Excel is a helpful tool to create a personal budget with its spreadsheets and functions. In this lab we will create a typical budget, as well as a budget for a dream vacation.

**Step 1:**
Create a Lab4 folder in your CSE3 folder. Open Microsoft Excel and create a new “Blank workbook”. Save the file as Budget.xlsx in your Lab4 folder.

**Step 2:**
First, we will list sources of income:
- In cell B3:
  - Type in the word **Income:**
  - Make it bold by clicking the B button in the Font group of the Home tab on the Ribbon
- In cell C4:
  - Type a list of your sources of income
  - Example: (feel free to include other sources of income other than the examples)
    - Job
    - Investments
    - Lottery
  - Each source should be in its own cell
- You can resize the columns to best display the data
- After your list, skip a line and enter **Total Income:** in Column C. Bold the entire row.

**Step 3:**
Next, we create a list of expenses. Unfortunately, we can’t put away 100% of our earnings towards our vacation. We must first pay for all our bills and necessities.
- Below the line for **Total Income:**
  - Skip a line and then type **Expenses** in Column B
  - Make it bold
- Underneath **Expenses**, in Column C, create a list of all your living expenses
  - Example: (be sure to include whatever you have to pay for)
    - Housing
    - Utilities (electricity, AC/heat, gas, internet)
    - Food
    - Transportation (bus/subway pass, gas, etc.)
    - Healthcare
    - Student Loan
    - Personal Expenses (e.g., clothes, entertainment, gifts, etc.)
Step 4:
- When you’ve entered all of your living expenses, skip a line and write **Total Expenses** in Column C. Bold the entire row.
- Finally, skip another line and write **Savings** in Column C. Again, make this entire row bold.
- Your final list should look something like the right image.

Step 5:
- Now move back up to the top:
  - In cell D2 write **Annual**
  - In cell E2 write **Monthly**
  - In cell F2 write **Weekly**
  - In cell G2 write **Daily**
- Select the entire second row by clicking on the number 2 on the left-hand side of the spreadsheet and make it bold.
- Select cells D4:G21 (this may be different depending on your lists’ length. On the **Home** tab, under the **Number** group, change “**General**” to “**Accounting**”, or press the **“$”** button.

Step 6:
We are now going to use some basic formulas to calculate information.
- In cell D4 enter **=E4*12**. E4 is our monthly value, our yearly value will be twelve times that.
- Now make sure cell D4 is selected and use the fill handle to copy the formula in D4 down to whatever line your **Savings** is on. For our example, we will go down to D21.
- Click on cell D18 and notice how it says **=E18*12**. Notice how this contrasts with the formula in cell D4. In cell D4 for formula was **=E4*12**. Since we used **relative naming** of the cells in the original formula, the auto fill feature has made the formula relative to the cell that we selected.
- Let’s make sure our formula works. Enter the value **10,000** into cell E4. You should see a calculated value appear in D4.
- Did your formula in cell D4 work? Does D4 contain #######? If you see this, it means the cell does not have enough room to display the full data in it.
- To fix this, auto-size the column by double clicking the border line between Columns D and E.
- If your formula worked, you should see **$120,000.00** in cell D4.
Step 7:
For some of our expenses, we may know the annual values. For others, we may only know monthly values. Let’s enter a formula for the monthly column, Column E.

- In cell E4, enter the formula `=D4/12`. The monthly value is the yearly value divided by 12.
- Uh oh, what happened? A circular reference warning! A circular reference occurs when the value of one cell relies on second cell, and the value of the second cell relies on the value on the first one. Because both cells depend on the other, it is impossible to compute a value for either cell. Excel uses a blue arrow between two cells that are involved in a circular reference.
- For now, we are going to ignore the warning, so just click OK on the dialog box.
- Make sure cell E4 is selected and drag the fill handle down to the column until the line Savings is on. For our example we go to Row 21.
- We know that there are 365 days in a year. So in cell G4 enter the formula `=D4/365`. Use the fill handle to copy the formula down the column until the Savings row. In our example it is row 21.
- Now in cell F4 enter the formula `=G4*7`. Use the fill handle to copy the formula down the column until the row Savings is on. Think about why do we divide by 12.
- We have copied our formulas into some cells that should remain blank. The lines above the bolded Total Income, Expenses, Total Expenses, and Savings should be blank. In our example, we remove the formulas in Rows 7, 9, 18 and 20 by pressing the <Delete> key.
- Let’s also remove the extraneous formulas from the cells next to Expenses.

Now your spreadsheet should look something like this:
Step 8:
Now let’s enter in some data into our budget spreadsheet. You don’t have to use real numbers, but you can get the earnings for different projected careers from internet. The US Dept. of Labor "Bureau of Labor Statistics" gives an estimated earnings salary for careers in the "Occupational Outlook Handbook". You can find them in this website: http://www.bls.gov/ooh/

Here is the sample summary for "Software Developers" from BLS website.

Summary

<table>
<thead>
<tr>
<th>Quick Facts: Software Developers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>2016 Median Pay</strong></td>
</tr>
<tr>
<td>$102,280 per year $49:17 per hour</td>
</tr>
<tr>
<td><strong>Typical Entry-Level Education</strong></td>
</tr>
<tr>
<td>Bachelor's degree</td>
</tr>
<tr>
<td><strong>Work Experience in a Related Occupation</strong></td>
</tr>
<tr>
<td>None</td>
</tr>
<tr>
<td><strong>On-the-job Training</strong></td>
</tr>
<tr>
<td>None</td>
</tr>
<tr>
<td><strong>Number of Jobs, 2014</strong></td>
</tr>
<tr>
<td>1,114,000</td>
</tr>
<tr>
<td><strong>Job Outlook, 2014-24</strong></td>
</tr>
<tr>
<td>17% (Much faster than average)</td>
</tr>
<tr>
<td><strong>Employment Change, 2014-24</strong></td>
</tr>
<tr>
<td>186,600</td>
</tr>
</tbody>
</table>

Find your preferred occupation, enter the annual wage in the Annual column for Job income (in our example, it will be in cell D4).

For the expenses, you can use the “Average annual expenditures of consumers” from this link http://www.bls.gov/news.release/cesan.htm. You can also make estimates based on your current expenses (you will have to do so for categories that don’t show in the link).
If you included Investments as a source of income but don’t have any, we can make an assumption. We will learn about the income from stocks in next week’s homework.

For Lottery, we’re going to demonstrate a neat Excel function and use =RANDBETWEEN(-100,1000) in the function bar. This will give you a randomly generated number between -100 and 1000 to be used as extra (or negative) income for you. A value will be randomly generated after some changes are made to your file.

Generally, Utilities are approximately 20% of your rent.

Student Loan payment amount can vary greatly depending on the size of the loan and the payment plan. $170/month is a good estimate for our purposes.

- If you have no student loans enter $0.

Fill in all the information.

Remember to use Paste Special if copying and pasting in order to retain the formatting of the cells.

Don’t fill in the Total Income, Total Expenses or Savings cells just yet.

Step 9:
Once you have all of the data calculated, we can start calculating totals.

- For Annual Total Income let’s use the AutoSum button to calculate the total.
- Select the D cell to the right of Total Income and click on the AutoSum button. You should see
something like this:

- By default, the AutoSum button selects the cells immediately above the selected cell that have data in them. In this case it has included a cell (D7) that we don’t want.
- To manually choose the cells that are summed together, click and drag cells D4 through D6.
- Press the check mark on the formula bar or press <Enter> to finalize your selection.
- If you see ####### in any column, remember that you can auto-fit and adjust the column width by double clicking on the border line between columns at the top of the sheet.
- Now let’s calculate our Total Expenses. This time, instead of using the AutoSum button let’s enter the formula by hand.
  - For our total expenses in the example we are summing from D11 to D17. Be sure to sum from where your list of expenses begins to where your list of expenses ends.
  - In Excel to specify a range use the colon “:”. If you type D11:D17 this means use cells D11 through D17.
  - Click on the Column D at the row where you have Total Expenses. For our example we will use D19. There we will write =SUM(D11:D17).

**Step 10:**
Once you have calculated your Total Income and Total Expenses you can calculate the difference to determine how much Savings you have.
- Your Savings formula should subtract Total Expenses from your Total Income.
- For our example, we will go to cell D21 and type in =D8-D19
- All your circular references warnings should be gone now.

Your page should look something like this:
Step 11:
At this point, things may look a little too good to be true, and that’s because they are. We forget one key aspect of accounting when building our budget: TAXES.

- Create one additional subsection underneath **Income** but above **Expenses** by selecting the empty row between them, right clicking, and then selecting **Insert**. Repeat this 6 more times so that you have inserted a total of 7 blank rows between **Total Income** and **Expenses**.
- For this assignment, we will assume that all of you will be working in California in the United States. Using the following websites, look at the tax rate that you would be paying given your net income:
  - California: [http://www.tax-brackets.org/californiataxtable](http://www.tax-brackets.org/californiataxtable)

- We will add label for **Taxes** in Column B. Then in Column C add two categories of taxes: **Federal**, **State**, and “Sunshine Tax”, then skip a line and add a **Total Taxes** category.
- The result will look similar to the table below:
Let’s set up our formulas again for **Annual, Monthly, Weekly, and Daily**.

- Refer back to Step 7 if you have forgotten these formulas.

First, tackle the **Federal taxes**.
- Tax calculations are fairly complicated. To simplify it for our purposes, let’s assume we make between $91,151 - $190,150. Then we will be paying a constant rate of 28%.
- In the **Annual** column for Federal taxes enter the following formula: \( =.28 \times D8 \) (The row of D will be different if you used different items for income)
- The formula is essentially just \([.28 \times \text{your yearly income}]\).

Second, for the **State taxes**.
- Assuming most of us make $51,530 - $263,222, we will be paying 9.3% of our income.
- In the **Annual** for State taxes, enter \( =.093 \times D8 \)

Lastly, “sunshine tax” is the term used for the increased cost of living in areas with nice weather (San Diego is one of these places!).
- We will simulate this by adding an extra 2% tax to our income.
- In the **Annual** column for Sunshine Tax, enter \( =.02 \times D8 \)

Now, calculate the sum in the total taxes section using the sum formula from earlier.

Finally, update your yearly savings calculation by modifying the current formula to subtract off the amount of money lost to taxes.

If your updated Savings values appear in parentheses, it means that they are **negative**. Try adjusting your expenses to fit within a budget your income allows. Maybe you need to find cheaper housing or reduce your personal expenses.
**B. Vacation Budget**

**Step 12:**
Now that we’ve calculated our general budget, let’s figure out how much our dream vacation costs. This should be customized for your personal vacation choice. Let’s plan for a week-long vacation.
- In cell I3, type **Vacation:** and make it bold.
- Now we are going to list the various expenses we need to budget for on our vacation. In cell J4, start listing these expenses:
  - **Transportation** (flights, train, taxi fare, bus fare, etc.)
  - **Hotel**
  - **Food** (3 meals/day for one week)
  - **Beverage** (Water, soda, etc.)
  - **Activities** (tours, entrance fees, entertainment, etc.)
  - **Miscellaneous** (tips, emergency funds, etc.)
- Select the corresponding cells in Column K and make them Accounting type (see Step 5).

**Step 13:**
Now let’s fill out each category:
• For **Transportation** (flights + car) and **Hotel**, you can use [www.expedia.com](http://www.expedia.com) to look up prices. Make sure to find round-trip tickets, a week apart. If you are taking other methods of transportation (train, bus, etc.) use Google to look up the appropriate costs.

• **Meals**: Your budget for meals will strongly depend on where you are traveling. One option is to use Google to look up a restaurant menu in the area, and calculate how much a day of meals would cost. Alternatively, we can simplify it by estimating $10 (breakfast) + $20 (lunch) + $30 (dinner) = $60 per day. So for a 7-day trip, we need $420 for meals.

• **Beverages**: Don’t forget to hydrate! Set aside some money to purchase drinks!

• **Activities**: Look up the costs for the activities you are interested in (museums, concerts, etc.).

**Step 14:**

• After your last vacation expense option, skip a line and type **Total Vacation Expenses**: in Column J. On the same row, in Column K, add up all your vacation expenses using the AutoSum button, or the regular SUM function.

• At this point, your vacation section should look something like this:

<table>
<thead>
<tr>
<th>Vacation:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Transportation</td>
<td>$1,000.00</td>
</tr>
<tr>
<td>Hotel</td>
<td>$800.00</td>
</tr>
<tr>
<td>Meals</td>
<td>$440.00</td>
</tr>
<tr>
<td>Beverages</td>
<td>$500.00</td>
</tr>
<tr>
<td>Activities</td>
<td>$1,000.00</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>$200.00</td>
</tr>
<tr>
<td><strong>Total Vacation Expenses:</strong></td>
<td><strong>$3,940.00</strong></td>
</tr>
</tbody>
</table>

**Step 15:**

• Skip another line and type **Days Until Vacation**: in Column J. In the same row, Column K, calculate the number of years you need to save for your vacation. The formula should be, 

\[ \text{Years} = \frac{\text{Total Vacation Expenses}}{\text{Daily Savings}} \]

In the example, this is \( =K11/G28 \).

• But this gives a decimal number. To get whole months, let’s use the \texttt{CEILING.MATH()} function to round up. Note that we can’t round down, otherwise we won’t have enough money saved to take our vacation. So, the formula in cell K14 becomes \( =\text{CEILING.MATH}(K11/G28) \).

• Depending on your income, spending habits, and type of vacation you want to take, you may have to save for many, many months or years!
Now, our entire budget spreadsheet looks something like:

Step 16:
Your Budget is done! Now, let’s create a pie chart of our everyday expenses to see if our expenditures match our priorities (i.e., spending more on necessities than extras).

- Select the cells in columns C and D under your Expenses section that have numbers in them.
- In our example, we would select cells C17:D23.

- On the Insert tab of the Ribbon, select one of the Pie Chart options in the Charts group.
• You should now see a pie chart of your Expenses.
• Under the Chart Tools > Design tab, play with how you want your data displayed:
  o In Quick Layout, you can choose the first option to display percentages by sections.
  o Give your chart a title.
• Now, let’s add a Bar Graph for the expenses data.
  o As before, select the same data ranges for Expenses and then from the Insert tab, select Column or Bar Graph type and select a Bar Graph type.
  o Add a title and adjust the formatting to your liking.

• The final charts should look something like this:

![Pie Chart](image1.png) ![Bar Graph](image2.png)

C. Putting it all online

Modify your CSE3Page.html to include a link to your Budget.xlsx file.

(If you really don’t want your budget information online, you can demonstrate to the TA/tutor that you did the work by showing them your Budget file on your computer, WITHOUT putting it online.)

Remember to either drag your ENTIRE CSE3 folder into your public_html folder OR into the WHITESPACE inside the public_html folder!

Lab Checkoff: Deonstrate to the TA/Tutor that your Budget.xlsx is complete. It should have:
  • Budget table with income, taxes, and expenses
  • Vacation budget table
  • A pie chart
  • A bar graph