A. Stock Performance

As we saw in Lab 4, Excel is a useful tool for managing, manipulating, and analyzing financial data. To help explore Excel more fully, in this assignment you are going to analyze the performance of the stocks of some companies related to your career in which you may want to invest your money in the future.

Step 1:
Create a Hw5 folder in your CSE3 folder.
Open a new Microsoft Excel spreadsheet and save it as StockPortfolio.xlsx in your Hw5 folder.

Step 2:
Create a list of four different companies

1. They cannot be completely identical to the ones used in class
2. 2 of your 4 companies must be related to your field of study.

- To select companies and find their stock prices, go to https://finance.yahoo.com/screener/new. Here, you are presented with a page to filter stocks. You can click on the “Add Sector Button” to find companies based on a general sector category (healthcare, technology, etc). You can then narrow your search even further if you would like by selecting a specific industry.
- For the fifth “company”, we will examine a different type of investment: the Bitcoin market (learn more here: http://www.coindesk.com/information/what-is-bitcoin/). Note that this type of investment is not the same as stock trading, and investing in Bitcoin remains a highly controversial topic. For the purposes of this assignment, we will treat this as a “stock” and Bitcoin as a “company”, though it is really a currency.

Notes for finding companies to use:

- If the screener says “Unable to load screener”, please refresh the page and enter different search criteria.
- Alternatively, if you know what companies to choose, you can type the name in the top search box “Search for news, symbols, or companies”. If your company is listed, your search should show your company’s name below the search bar and its stock’s “Ticker”.
• In cell B4, type the heading **Company Name** and list the names of the four companies you selected in cells B5:B8. Type **Bitcoin** in cell B9. Resize the columns as needed.

• Now, highlight cells B4:N4. With these cells highlighted, apply cell style “Heading 3” by selecting it on the home tab under “Styles” on the ribbon. These will be the headers for our columns and we will fill the rest out as we go.

• For each company, get the Close Price of shares for the dates of our first 4 Monday lectures. You can find the dates on the course page.
  - You may find a company’s past prices under the **Historical Data** tab under the listing for each company on [http://finance.yahoo.com/](http://finance.yahoo.com/).

  - For Bitcoin, the closing price is on the CoinDesk website ([http://www.coindesk.com/price/](http://www.coindesk.com/)). There should be an **Export Button** with a range of dates that links to a .csv file with closing prices. This can be opened in Excel. Adjust the dates so that they include the first 4 Monday lectures and download the data.

• In the cells C4:F4, list the dates of the first 4 Monday lectures. They should be in the date format of ‘4-Apr’, ‘10-Oct’, etc.

• Now enter **Total** in cell B10 and apply the “**Total**” cell style to the range B10:N10.

• Now select all of the data in your table and apply the accounting formatting by clicking the button with the “$” sign on the ribbon home tab.

• After you have entered your data and applied the formatting, your table should look something like this:
B. Comparison of Prices

Now we will create a column chart that shows us the comparison between the prices for each company for the chosen four dates.

- Select the data in the table B4:F9. Go to the Insert tab and find the Charts section. Click on the Column Chart button. Choose whichever style of column chart you like.

- You can play with the different preset styles under Chart Styles.

- If your graph looks like the one below, click on the Switch Row/Column button (boxed in the picture above)
- Change the title to **Price Comparison**

You should end up with something similar to this:
C. Buy Stock & Investment
Suppose you bought 15 shares of each of these five companies on the first CSE3 Monday lecture. We would like to calculate how much you would have invested in stock.

- In cell B11 type **Shares** and make the cell **bold**. In cell C11 type in the number 15 as the value for the number of shares. If the number is formatted in the Accounting style, use the dropdown to select the “number” formatting and use the buttons to decrease the number of decimal places.
- Type in an **Investment** heading for Column G.
- Fill the **Investment** column with the formula for multiplying shares with the stock prices for Lab 1. That is, you want to multiply the values in the Column C with the value in cell C11 and put the results in Column G. The formula in cell G5 should be: =C5*C11. Drag and autofill the rest of the values for that column.
- **But wait!?** Why are the rest of the results showing up as $ - ? This is because Excel uses relative referencing by default when using the autofill feature to apply formulas and cell locations to other cells. If you select cell G6 you will see the formula is ‘=C6*C12’, cell G7 has the formula ‘=C7*C13’, etc. So when we used autofill down the column, the cell locations were relative down the column. But we just want our Investment formulas to always reference the number value of Shares in cell C11, not any other cell in the C column. To refer to a constant cell location, we want to use absolute referencing by using the ‘$’ symbol for cell locations.
- Edit the formula in cell G5 to =C5*$C$11 and autofill the rest of the values down the column.
  - What ‘C$11’ means is that we want the row (Row 11) to be constant, but the column letter can change. ‘$C11’ would mean the column (Column C) will stay constant, but the row number can change. ‘$C$11’ would indicate an exact constant cell location.
- Now we would like to see the **Total Investment**. In the **Total**: row, under the G column, calculate the sum. You can use the AutoSum button.
• Now we want to see the division of our investment in a pie chart. Select the company names B5:B9. Then hold the <Ctrl> key while selecting the investments G5:G9 (so that the company names and investments are selected at the same time).

• Under the Insert tab, find the Charts section. This time choose Pie and select a pie chart.

• Select the newly created pie chart and under the Chart Design tab, use the Quick Layout button to choose a layout style that has percentages. Set the chart title to: Investment.

You should end up with something like this:

![Image of pie chart with company names and investment percentages]

D. Profit/Loss

Now we want to find out the percent profit or loss for each company and display them on a chart.

• Create three columns with headings Current Value, Net Income and %Profit/Loss. To calculate, type the equations into the 5th row of the columns above (respectively) and then drag down to fill the rest of the cells in that column.

• For example, In the Current Value column, calculate the current value of the stock with a formula for multiplying the number of shares, found in cell C11, with the prices of the latest week. You want to multiply the values in the Column F and cell C11 and put the result in Column H. The formula in H5 should be: =F5*$C$11. Drag and autofill the rest of the values for that column.
• Now we would like to see the Total Current Value of stock. In the Total: row under the H column, calculate the sum using the AutoSum button.

• To compute the Net Income, subtract the values in the Investment column from the Current Value column. You can use this formula =H5-G5. Drag and autofill the rest of the values for that column. Also compute the Total Income.

• The %Profit/Loss can be calculated by dividing Net Income by Investment. Drag and autofill the rest of the values for that column. To display this as a percentage, select J5:J9 and click the % button in the Number section of the Home tab.

• In the %Profit/Loss column, we want to see two decimal places in our percentages. Select the data in that column and under the Home tab in the Number section use the buttons to increase/decrease the number of decimal places.

After you do this your table should look like this:

<table>
<thead>
<tr>
<th>Company Name</th>
<th>3-Apr</th>
<th>10-Apr</th>
<th>17-Apr</th>
<th>24-Apr</th>
<th>Investment</th>
<th>Current Value</th>
<th>Net Income</th>
<th>Profit Loss</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disney</td>
<td>$113.20</td>
<td>$112.43</td>
<td>$113.78</td>
<td>$113.70</td>
<td>$1,698.00</td>
<td>$1,705.50</td>
<td>$7.50</td>
<td>0.44%</td>
</tr>
<tr>
<td>Netflix</td>
<td>$146.92</td>
<td>$143.85</td>
<td>$147.25</td>
<td>$143.83</td>
<td>$2,203.80</td>
<td>$2,157.45</td>
<td>$(46.35)</td>
<td>-2.10%</td>
</tr>
<tr>
<td>Intel</td>
<td>$36.16</td>
<td>$35.80</td>
<td>$35.48</td>
<td>$36.75</td>
<td>$542.40</td>
<td>$551.25</td>
<td>$8.85</td>
<td>1.63%</td>
</tr>
<tr>
<td>Amazon</td>
<td>$891.51</td>
<td>$907.04</td>
<td>$901.04</td>
<td>$907.41</td>
<td>$13,372.65</td>
<td>$13,611.15</td>
<td>$238.50</td>
<td>1.78%</td>
</tr>
<tr>
<td>Bitcoin</td>
<td>$1,128.23</td>
<td>$1,211.22</td>
<td>$1,184.94</td>
<td>$1,243.23</td>
<td>$16,923.45</td>
<td>$18,648.45</td>
<td>$1,725.00</td>
<td>10.19%</td>
</tr>
<tr>
<td>Total:</td>
<td>$34,740.30</td>
<td>$36,673.80</td>
<td></td>
<td></td>
<td>$36,673.80</td>
<td>$36,673.80</td>
<td>$1,933.50</td>
<td></td>
</tr>
<tr>
<td>Shares</td>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

• Now we want to see the %Profit/Loss in a column chart. Select the company names B5:B9 and %Profit/Loss J5:J9 at the same time by holding the <Ctrl> key.

• Again, use Charts under the Insert tab to insert a Column chart. As before, you can play around with the Chart Styles and layout options under Quick Layout in the Design tab.

You should get something like this:
E. Function IF

One of the most powerful features in Excel is to evaluate data conditionally based on its value.

Let’s say we want to evaluate our stocks’ growth based on the percent profit and loss. We want to add a new column that tells us about the growth of each company. We can accomplish this with the use of IFs, ANDs, and ORs. Suppose we classify a company as rising if %Profit/Loss is greater than 10%, failing if %Profit/Loss is less than -1%, and neutral otherwise.

Recall from Homework 4 that the IF formula has the following format:

\[=IF(\text{question\_to\_test}, \text{result\_if\_true}, \text{result\_if\_false})\]

Let’s solve this together:

- Enter the heading Growth in column K. We are going to enter our formula in cell K5.
- Click either the Insert Function button or the function icon on the formula bar.

- Look for and select IF. Click OK.
• In the dialog box enter the values:
  o Logical_test: J5 > 0.01
  o Value_if_true: “Rising”. Be sure to include the quotation marks!
• Select OK

Now use the fill handle to copy the formula through cells K5:K9.

Note that we used 0.01 to represent 1%, because although they display as numbers 1-100, Excel has stored them as numbers in the range 0-1.

We also wanted to mark stocks as “Falling” if %Profit/Loss < -1%, and neutral otherwise. We need to add another ‘IF’ in our formula. If the test for rising is FALSE, then we want to test for
falling. What we need to do is nest another ‘IF’ formula inside of our ‘IF’ formula. This is called a nested if. Pictorially:

Let’s edit the formula we have in K5:
- Select cell K5.
- Click one of the Function buttons. You should see the function arguments dialog box.
- In Value_if_false enter \text{IF}(J5<-0.01, "Falling", "Neutral")
- Use the fill handle to copy our new formula through K5:K9

Your table should look similar to this:

<table>
<thead>
<tr>
<th></th>
<th>3-Apr</th>
<th>10-Apr</th>
<th>17-Apr</th>
<th>24-Apr</th>
<th>Investment</th>
<th>Current Value</th>
<th>Net Income</th>
<th>Profit Loss</th>
<th>Growth</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disney</td>
<td>$113.20</td>
<td>$112.43</td>
<td>$113.78</td>
<td>$113.70</td>
<td>$1,698.00</td>
<td>$1,705.50</td>
<td>$7.50</td>
<td>0.444</td>
<td>Neutral</td>
</tr>
<tr>
<td>Netflix</td>
<td>$146.92</td>
<td>$143.85</td>
<td>$147.25</td>
<td>$143.83</td>
<td>$2,203.80</td>
<td>$2,157.45</td>
<td>($46.35)</td>
<td>-2.10%</td>
<td>Falling</td>
</tr>
<tr>
<td>Intel</td>
<td>$36.16</td>
<td>$35.80</td>
<td>$35.48</td>
<td>$36.75</td>
<td>$542.40</td>
<td>$551.25</td>
<td>$8.85</td>
<td>1.63%</td>
<td>Rising</td>
</tr>
<tr>
<td>Amazon</td>
<td>$891.51</td>
<td>$907.04</td>
<td>$901.04</td>
<td>$907.41</td>
<td>$13,372.65</td>
<td>$13,611.15</td>
<td>$238.50</td>
<td>1.78%</td>
<td>Rising</td>
</tr>
<tr>
<td>Bitcoin</td>
<td>$1,128.23</td>
<td>$1,211.22</td>
<td>$1,184.94</td>
<td>$1,243.23</td>
<td>$16,923.45</td>
<td>$18,648.45</td>
<td>$1,725.00</td>
<td>10.19%</td>
<td>Rising</td>
</tr>
<tr>
<td>Total</td>
<td>$34,740.30</td>
<td>$36,673.80</td>
<td>$36,433.50</td>
<td>$36,233.50</td>
<td>$536,740.30</td>
<td>$548,673.80</td>
<td>$19,933.50</td>
<td>1.09%</td>
<td></td>
</tr>
<tr>
<td>Shares</td>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Using the same conditions, we would like to add icons as a visual indicator of the profit/loss:
- First, make sure you are in the Home tab.
- Now select the cells that correspond to our %Profit/Loss column (J5:J9).
- Click on the Conditional Formatting button, then New Rule from the drop-down menu.
• In the pop-up box, choose **Format Style**: ‘Icon Sets’.

• For **Icon Style**, choose the set that looks like: ▼ ▼ ▲. You may have to scroll down the list to find it.

• Change both **Type** boxes to ‘Number’. Enter the conditions that we previously set (i.e., Rising if greater than 1%, Falling if less than -1%, and Neutral otherwise).

Your table should look similar to this:
F. Trends and predictions

The calculation features of Excel not only allows us to make visual representations of what happened in the past, it also allows us to predict future values. For the purpose of this assignment, we will be using the Excel Trend function to forecast the stock price for the 5th week using stock prices from the previous four weeks. The Trend function calculates or predicts the future value along a linear trend using past existing values.

Then we will calculate the income based on the predicted price. We want to add three new headers, Sparklines in column L, Trend in column M and Predicted Income in column N.

- First we want to add a visual representation of the trend. To do this, we use a function of Excel called spark lines.
- Select cell L5 and click the Sparkline option in the insert tab. Select line.
- When you select the line option, it will ask for a range of data. Input C5:F5 for your range and use the fill handle to complete the other 4 companies.
- You should now see something like this in your L column:

- In the cell M5, insert the TREND function.
- Use the following function: =TREND(C5:F5,1,2,3,4,5) to predict the price for the 5th week. Drag the mouse to autofill the forecast for the other stocks. This looks like:
• Then use the formula \( \text{Predicted Income} = (\text{Trend} \times \text{Shares}) - \text{Investment} \) to fill out the Predicted Income column. So the formula in \( N5 \) is \( = (M5 \times SC11) - G5 \). This is the predicted income if we waited one more week before selling our shares.
  
• Autofill this formula for the column.
  
• Use the AutoSum button to total the predicted income.

Your newest columns should look similar to this:

<table>
<thead>
<tr>
<th>%Profit/Loss</th>
<th>Growth</th>
<th>Sparkline</th>
<th>Trend</th>
<th>Predicted Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>0.44%</td>
<td>Neutral</td>
<td>$113.99</td>
<td>$11.85</td>
</tr>
<tr>
<td>-2.15%</td>
<td>Falling</td>
<td>~~</td>
<td>$144.00</td>
<td>$(43.87)</td>
</tr>
<tr>
<td>1.61%</td>
<td>Rising</td>
<td>~~~</td>
<td>$36.41</td>
<td>$3.75</td>
</tr>
<tr>
<td>1.75%</td>
<td>Rising</td>
<td>~~~</td>
<td>$912.18</td>
<td>$309.98</td>
</tr>
<tr>
<td>9.25%</td>
<td>Rising</td>
<td>~~~</td>
<td>$1,271.59</td>
<td>$2,150.33</td>
</tr>
</tbody>
</table>

$2,432.03

Spend some time thinking about whether you want to buy/sell some stock based on comparison of your current income and predicted income. Was it better to do it last week or should we have waited until this week?

G. Cell Merging
Now we would like to put a title for the table that will be at the top-center of the table.

- Select the cells B2:N2.
- Select Merge & Center in the Home tab.

<table>
<thead>
<tr>
<th>File</th>
<th>Home</th>
<th>Insert</th>
<th>Page Layout</th>
<th>Formulas</th>
<th>Data</th>
<th>Review</th>
<th>View</th>
<th>Tell me what you want to do...</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Type Stock Portfolio in the merged cell and apply the “Title” cell style to it.
- Now under the “Page Layout” tab on the ribbon, you can apply whatever Theme you want by clicking this button:
- Be creative! Apply whatever themes/colors/fonts you like!

Your final spreadsheet should look something like this with your own theme:

![Excel Spreadsheet]

H. PRESENTATION

Now we will create a PowerPoint presentation with all the charts you have created.

**Step 1:**
Open PowerPoint 2016 through the Start menu. Choose Blank Presentation. Save this file as Stocks.pptx in your Hw5 folder (which is in your CSE3 folder).

**Step 2:**
You’ll see two empty boxes which say “Click to add title” and “Click to add subtitle.” The first one should be the title of your presentation. Title it something like ‘Stock Performance’ or ‘Investment Portfolio’. The second box should have your name.
**Step 3:**
Select the **Design** tab on the ribbon and select a Theme you like from the **Themes** group.

**Step 4:**
Now insert a new slide by going to **Home** tab and selecting **New Slide** from the **Slides** section. Choose **Title and Content** as your slide type. You should now see a blank slide.

**Step 5:**
Switch back to your **Stock.xlsx** page and copy a chart using Ctrl-C. Use Ctrl-V to paste the chart into the body of the slide. Give your slide a title.

**Step 6:**
Now for the most fun part of the PowerPoint—animations!
- Select part of your slide – the title or the chart itself.
- Choose the **Animations** tab on the ribbon and select the **Animation Pane** button in the **Advanced** Animation group.
- A new pane should open up on the right-hand side of your screen.
- Click **Add Animation** and play around with some of the animation features.

**Step 7:**
In the **Insert** tab select **Header & Footer**.

The dialogue box below will pop up.
- Check **Date and time**, and select **Fixed** to automatically put today’s date on every slide.
- Check **Slide number** to number the slides.
- Check **Footer** and type **CSE 3 HW 5, Spring 2017** to label each slide.
- Check the “Don’t show on title slide” box, to keep the title slide clean.
- Finally, press the **Apply to All** button to apply these updates to every slide.
**Step 8:**
Create new slides and insert the rest of your charts. Add an animation to each new slide. You will notice that your Footer automatically appears on the new pages. Save everything.

You should have a total of 4 slides when you’re done:
- One title slide
- 3 slides with charts

**Step 9:**
When you are finished with your presentation, also save it as a PDF (i.e., Stocks.pdf). Note that when viewing your presentation PDF, the animations will not play. To see the animation, you must open the .pptx PowerPoint file.

**I. Putting it all online**

**Step 1:**
Modify your CSE3Page.html to include a link to your Stocks.pdf file.

**Step 2:**
Put everything online and get checked off.

Please be sure to close both Microsoft Excel and PowerPoint before transferring your files.

REMEMBER to drag your ENTIRE CSE3 folder into the WHITESPACE inside the public_html folder!!!!
Take a minute and think about how you have multiple *copies* of your Excel files and PowerPoint files – on your computer and on the internet. While the contents contained in these files may be the same, they are still separate and unique file copies of one another.

**Homework Checkoff:** Demonstrate to the TA/Tutor

- **Excel Spreadsheet**
  - Four companies and Bitcoin closing prices
  - The three charts showing Comparison of Prices, Investment and %Profit/Loss
  - Working “Growth” column formula and conditional formatting
  - Working “Trend” column formula and predicted income
  - Sparklines
  - The title with the merged cell

- **PowerPoint Presentation**
  - One title slide
  - 3 slides with charts
  - Proper Footer on every slide (except title slide)